in Uncategorized

HTML Components specification *finally* revisited as Widgets?

They’re calling them Widget now, but essentially this is almost what the HTML Components specification from 1998 was trying to do. I do like the fact that includes a packaging mechanism (ZIP) so that you can distribute all your resources in on file.

Criticism follows:

  • There should be a way to expose an interface for my widget (properties, methods, events) just like the HTML component specification. These could be declared in the config.xml.
  • The config.xml should have a namespace.
  • The “id” element… not sure it makes sense. Should probably be a URI.
  • Naming Nitpicks:
  • Should we use “index.html”? It already has meaning, why overload it? How about “widget.html”?
  • The “widgetname” be camel-cased as “widgetName”.
  • Widget scripting interface’s “preferenceForKey” should be “getPreferenceForKey”.

Leave a comment